Slower than expected email delivery

Resolved
Degraded performance
Started over 2 years ago Lasted about 3 hours

Affected

Core Backend
Email Sending
Updates
  • Resolved
    Resolved

    The queues are clear and sending is back to normal speeds. Thanks for your patience today.

  • Monitoring
    Monitoring

    Our upstream provider have identified the issue causing sending delays and have deployed a fix. The queues will be clearing out shortly. Message delays are just around 1 minute now.

  • Investigating
    Investigating

    We are currently monitoring an issue causing emails to be processed slower than expected resulting in delivery delays. This is due to an issue with our upstream provider.